ฉันเพิ่งเริ่มใช้ VSCode พบข้อผิดพลาดนี้และลองวิธีแก้ไขแต่ไม่ได้ผล

นี่คือ launch.json ของฉัน

{
// Use IntelliSense to learn about possible attributes.
// Hover to view descriptions of existing attributes.
// For more information, visit: https://go.microsoft.com/fwlink/?linkid=830387
"version": "0.2.0",
"configurations": [
    {
        "name": "C/C++: Build and debug active file",
        "type": "cppdbg",
        "request": "launch",
        "program": "${fileDirname}\\${fileBasenameNoExtension}.exe",
        "args": [],
        "stopAtEntry": false,
        "cwd": "${workspaceFolder}",
        "environment": [],
        "externalConsole": true,
        "MIMode": "gdb",
        "miDebuggerPath": "C:\\TDM-GCC-64\\gdb64\\bin\\gdb.exe",
        "setupCommands": [
            {
                "description": "Enable pretty-printing for gdb",
                "text": "-enable-pretty-printing",
                "ignoreFailures": true
            }
        ],
        "preLaunchTask": "C/C++: g++.exe build active file"
    }
]

} ใส่คำอธิบายภาพที่นี่

* UPDATE: แก้ไขปัญหาโดยทำตามขั้นตอนเหล่านี้ด้านล่าง ไปที่แผงควบคุมของ Windows (คุณสามารถทำได้โดยเปิด File Explorer และในประเภทพาธ 'แผงควบคุม' (โดยไม่ใส่เครื่องหมายอัญประกาศ) และกด Enter);

1. จากแผงควบคุม ให้คลิกที่ 'นาฬิกาและภูมิภาค'

2. คลิกภูมิภาค หน้าจอใหม่จะเปิดขึ้น

3.ในหน้าจอที่เปิดขึ้น ให้คลิกที่ Administrative และค้นหาปุ่ม "Change system location"

4. ตรวจสอบตัวเลือก: "เบต้า: ใช้ Unicode UTF-8 สำหรับการสนับสนุนภาษาโลก"

5.รีสตาร์ทคอมพิวเตอร์

ไม่พบคำตอบ